use strict;
my $str = 'asdsad $59.33 9. .3 as.df 2 asdf 56 89 .a 2.4 wef 95 as.5df. 67.990 dssdgsfh.gdfgdlkblbllgff.njyn.j.njljn.jn.j.jnjnn.jn.n.n.vvfbvhfbhbfhbvhfbvhf.ghfghrughu.gktigjti';
my $regex = qr/[a-z] + [^0-9\s.]+|\.(?!\d)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";