import Foundation
let pattern = #"[a-z] + [^0-9\s.]+|\.(?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"asdsad $59.33 9. .3 as.df 2 asdf 56 89 .a 2.4 wef 95 as.5df. 67.990 dssdgsfh.gdfgdlkblbllgff.njyn.j.njljn.jn.j.jnjnn.jn.n.n.vvfbvhfbhbfhbvhfbvhf.ghfghrughu.gktigjti"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)