re = /[a-z] + [^0-9\s.]+|\.(?!\d)/
str = 'asdsad $59.33 9. .3 as.df 2 asdf 56 89 .a 2.4 wef 95 as.5df. 67.990 dssdgsfh.gdfgdlkblbllgff.njyn.j.njljn.jn.j.jnjnn.jn.n.n.vvfbvhfbhbfhbvhfbvhf.ghfghrughu.gktigjti'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result