using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\D)(?=\d+\b)";
string substitution = @",";
string input = @"NS01SP0001
ns01sp0001";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}