import Foundation
let pattern = #"(?<=\D)(?=\d+\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
NS01SP0001
ns01sp0001
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)