const regex = /(?<=\D)(?=\d+\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\D)(?=\\d+\\b)', 'g')
const str = `NS01SP0001
ns01sp0001`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);