$re = '/(?<=\D)(?=\d+\b)/';
$str = 'NS01SP0001
ns01sp0001';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;