use strict;
my $str = 'NS01SP0001
ns01sp0001';
my $regex = qr/(?<=\D)(?=\d+\b)/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";