#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[-+](?:[0-9]*[.])?[0-9]+|(?<=\(|\/|\*)[+-](?:[0-9]*[.])?[0-9]+|(?:[0-9]*[.])?[0-9]+|[-+*\/()]"
Local $sString = "-0.17+(24.4/-12.2)" & @CRLF & _
"" & @CRLF & _
"(17-13)/+0.5" & @CRLF & _
"" & @CRLF & _
"(9.25*((+12.5+1.3)-5.8))/(0.125*((13.2+2.8)*2))" & @CRLF & _
"" & @CRLF & _
"19-((34.99/1)+14" & @CRLF & _
"" & @CRLF & _
"((2.80-4.3)*((((9.3-2.3))+7)/3.5))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")