use strict;
my $str = '-0.17+(24.4/-12.2)
(17-13)/+0.5
(9.25*((+12.5+1.3)-5.8))/(0.125*((13.2+2.8)*2))
19-((34.99/1)+14
((2.80-4.3)*((((9.3-2.3))+7)/3.5))';
my $regex = qr/^[-+](?:[0-9]*[.])?[0-9]+|(?<=\(|\/|\*)[+-](?:[0-9]*[.])?[0-9]+|(?:[0-9]*[.])?[0-9]+|[-+*\/()]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}