$re = '/^[-+](?:[0-9]*[.])?[0-9]+|(?<=\(|\/|\*)[+-](?:[0-9]*[.])?[0-9]+|(?:[0-9]*[.])?[0-9]+|[-+*\/()]/';
$str = '-0.17+(24.4/-12.2)
(17-13)/+0.5
(9.25*((+12.5+1.3)-5.8))/(0.125*((13.2+2.8)*2))
19-((34.99/1)+14
((2.80-4.3)*((((9.3-2.3))+7)/3.5))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);