import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-+](?:[0-9]*[.])?[0-9]+|(?<=\\(|\\/|\\*)[+-](?:[0-9]*[.])?[0-9]+|(?:[0-9]*[.])?[0-9]+|[-+*\\/()]";
final String string = "-0.17+(24.4/-12.2)\n\n"
+ "(17-13)/+0.5\n\n"
+ "(9.25*((+12.5+1.3)-5.8))/(0.125*((13.2+2.8)*2))\n\n"
+ "19-((34.99/1)+14\n\n"
+ "((2.80-4.3)*((((9.3-2.3))+7)/3.5))";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}