using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[-+](?:[0-9]*[.])?[0-9]+|(?<=\(|\/|\*)[+-](?:[0-9]*[.])?[0-9]+|(?:[0-9]*[.])?[0-9]+|[-+*\/()]";
string input = @"-0.17+(24.4/-12.2)
(17-13)/+0.5
(9.25*((+12.5+1.3)-5.8))/(0.125*((13.2+2.8)*2))
19-((34.99/1)+14
((2.80-4.3)*((((9.3-2.3))+7)/3.5))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}