import Foundation
let pattern = #"^[-+](?:[0-9]*[.])?[0-9]+|(?<=\(|\/|\*)[+-](?:[0-9]*[.])?[0-9]+|(?:[0-9]*[.])?[0-9]+|[-+*\/()]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
-0.17+(24.4/-12.2)
(17-13)/+0.5
(9.25*((+12.5+1.3)-5.8))/(0.125*((13.2+2.8)*2))
19-((34.99/1)+14
((2.80-4.3)*((((9.3-2.3))+7)/3.5))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)