import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^ \\/?$])\\b(foo)\\b";
final String string = "foo - need this\n"
+ "<div>foo</div> - need this\n\n"
+ " foo - dont need this\n"
+ "Foo - dont need this\n"
+ "foobar - dont need this\n"
+ "/foo/ - dont need this";
final String subst = "$1bar";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}