re = /(^|[^ \/?$])\b(foo)\b/
str = 'foo - need this
<div>foo</div> - need this
foo - dont need this
Foo - dont need this
foobar - dont need this
/foo/ - dont need this'
subst = '$1bar'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result