import Foundation
let pattern = #"(^|[^ \/?$])\b(foo)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
foo - need this
<div>foo</div> - need this
foo - dont need this
Foo - dont need this
foobar - dont need this
/foo/ - dont need this
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1bar"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)