const regex = /(^|[^ \/?$])\b(foo)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^ \\\/?$])\\b(foo)\\b', 'g')
const str = `foo - need this
<div>foo</div> - need this
foo - dont need this
Foo - dont need this
foobar - dont need this
/foo/ - dont need this`;
const subst = `$1bar`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);