# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.{0,9}\w)\b\p{P}*/$1.../gmu;t' <<< "foo inside bar baz
quick brown fox
Have punct,"