use strict;
my $str = 'foo inside bar baz
quick brown fox
Have punct,';
my $regex = qr/^(.{0,9}\w)\b\p{P}*/mup;
my $subst = '$1...';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";