#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)^(.{0,9}\w)\b\p{P}*"
Local $sString = "foo inside bar baz" & @CRLF & _
"quick brown fox" & @CRLF & _
"Have punct,"
Local $sSubst = "$1..."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)