// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)^(.{0,9}\w)\b\p{P}*").unwrap();
let string = "foo inside bar baz
quick brown fox
Have punct,";
let substitution = "$1...";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}