$re = '/^(.{0,9}\w)\b\p{P}*/mu';
$str = 'foo inside bar baz
quick brown fox
Have punct,';
$subst = "$1...";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;