re = /^(.{0,9}\w)\b\p{P}*/m
str = 'foo inside bar baz
quick brown fox
Have punct,'
subst = '$1...'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result