# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+)(\|)(.+)(\|)(.+)/$1$3$4$5/gm;t' <<< "PR.CS|12|CS"