const regex = /(.+)(\|)(.+)(\|)(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+)(\\|)(.+)(\\|)(.+)', 'gm')
const str = `PR.CS|12|CS`;
const subst = `$1$3$4$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);