using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:noi)(?<space>(?:.*-.*))(?:csn\k<space>)?(?<noiNum>(?:txr12\w{3}f)|(?:txr15\d{7}))?(?:\k<space>)?(?<projName>(?:\b[\w\s\-\&]+?\b))(?:\k<space>).*?(?<noiNum2>(?:(?:trx12\w{3}f)|(?:txr15\d{7})))?(?:\.pdf)$";
string input = @"NOI - CSN - Riata Unit 5C - elec. - Fuquay - TXR150022379.pdf";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}