import re
regex = re.compile(r"(?i)(?:noi)(?<space>(?:.*-.*))(?:csn\k<space>)?(?<noiNum>(?:txr12\w{3}f)|(?:txr15\d{7}))?(?:\k<space>)?(?<projName>(?:\b[\w\s\-\&]+?\b))(?:\k<space>).*?(?<noiNum2>(?:(?:trx12\w{3}f)|(?:txr15\d{7})))?(?:\.pdf)$")
test_str = "NOI - CSN - Riata Unit 5C - elec. - Fuquay - TXR150022379.pdf"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")