import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?:noi)(?<space>(?:.*-.*))(?:csn\\k<space>)?(?<noiNum>(?:txr12\\w{3}f)|(?:txr15\\d{7}))?(?:\\k<space>)?(?<projName>(?:\\b[\\w\\s\\-\\&]+?\\b))(?:\\k<space>).*?(?<noiNum2>(?:(?:trx12\\w{3}f)|(?:txr15\\d{7})))?(?:\\.pdf)$";
final String string = "NOI - CSN - Riata Unit 5C - elec. - Fuquay - TXR150022379.pdf";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}