re = /(?i)(?:noi)(?<space>(?:.*-.*))(?:csn\k<space>)?(?<noiNum>(?:txr12\w{3}f)|(?:txr15\d{7}))?(?:\k<space>)?(?<projName>(?:\b[\w\s\-\&]+?\b))(?:\k<space>).*?(?<noiNum2>(?:(?:trx12\w{3}f)|(?:txr15\d{7})))?(?:\.pdf)$/
str = 'NOI - CSN - Riata Unit 5C - elec. - Fuquay - TXR150022379.pdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end