# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b0+(?:\B|\s[hm](?:\s|$))//gm;t' <<< "17 h 30 m
08 h 00 m
00 h 05 m"