package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b0+(?:\B|\s[hm](?:\s|$))`)
var str = `17 h 30 m
08 h 00 m
00 h 05 m`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}