const regex = /\b0+(?:\B|\s[hm](?:\s|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b0+(?:\\B|\\s[hm](?:\\s|$))', 'gm')
const str = `17 h 30 m
08 h 00 m
00 h 05 m`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);