re = /\b0+(?:\B|\s[hm](?:\s|$))/m
str = '17 h 30 m
08 h 00 m
00 h 05 m'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result