use strict;
my $str = '17 h 30 m
08 h 00 m
00 h 05 m';
my $regex = qr/\b0+(?:\B|\s[hm](?:\s|$))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";