// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b0+(?:\B|\s[hm](?:\s|$))").unwrap();
let string = "17 h 30 m
08 h 00 m
00 h 05 m";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}