#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\n\([^()]+\)\n.*?\n\([^()]+\)\n"
Local $sString = "speaker1: hello" & @CRLF & _
"" & @CRLF & _
"speaker2: hello (clears throat), let me show you something Ted Cruz said last week" & @CRLF & _
"" & @CRLF & _
"(begin audio clip)" & @CRLF & _
"" & @CRLF & _
"Ted Cruz (R-TX): My dad did not shoot JFK, why do people keep saying that?" & @CRLF & _
"" & @CRLF & _
"(end audio clip)" & @CRLF & _
"" & @CRLF & _
"speaker1: now isn't that interesting"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")