re = /\n\([^()]+\)\n.*?\n\([^()]+\)\n/m
str = 'speaker1: hello
speaker2: hello (clears throat), let me show you something Ted Cruz said last week
(begin audio clip)
Ted Cruz (R-TX): My dad did not shoot JFK, why do people keep saying that?
(end audio clip)
speaker1: now isn\'t that interesting'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end