package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)\n\([^()]+\)\n.*?\n\([^()]+\)\n`)
var str = `speaker1: hello
speaker2: hello (clears throat), let me show you something Ted Cruz said last week
(begin audio clip)
Ted Cruz (R-TX): My dad did not shoot JFK, why do people keep saying that?
(end audio clip)
speaker1: now isn't that interesting`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}