import Foundation
let pattern = #"\n\([^()]+\)\n.*?\n\([^()]+\)\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
speaker1: hello
speaker2: hello (clears throat), let me show you something Ted Cruz said last week
(begin audio clip)
Ted Cruz (R-TX): My dad did not shoot JFK, why do people keep saying that?
(end audio clip)
speaker1: now isn't that interesting
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)