import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n\\([^()]+\\)\\n.*?\\n\\([^()]+\\)\\n";
final String string = "speaker1: hello\n\n"
+ "speaker2: hello (clears throat), let me show you something Ted Cruz said last week\n\n"
+ "(begin audio clip)\n\n"
+ "Ted Cruz (R-TX): My dad did not shoot JFK, why do people keep saying that?\n\n"
+ "(end audio clip)\n\n"
+ "speaker1: now isn't that interesting";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}