using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n\([^()]+\)\n.*?\n\([^()]+\)\n";
string input = @"speaker1: hello
speaker2: hello (clears throat), let me show you something Ted Cruz said last week
(begin audio clip)
Ted Cruz (R-TX): My dad did not shoot JFK, why do people keep saying that?
(end audio clip)
speaker1: now isn't that interesting";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}