#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:([89]|[12][0-9]|3[0-5])(\.[0-9]{1,2})?|36)$"
Local $sString = "8.5" & @CRLF & _
"9.56" & @CRLF & _
"10.69" & @CRLF & _
"35.99" & @CRLF & _
"36" & @CRLF & _
"36.99" & @CRLF & _
"37" & @CRLF & _
"123" & @CRLF & _
"5.9866" & @CRLF & _
"5.5" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")