use strict;
my $str = '8.5
9.56
10.69
35.99
36
36.99
37
123
5.9866
5.5
';
my $regex = qr/^(?:([89]|[12][0-9]|3[0-5])(\.[0-9]{1,2})?|36)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}