// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:([89]|[12][0-9]|3[0-5])(\.[0-9]{1,2})?|36)$").unwrap();
let string = "8.5
9.56
10.69
35.99
36
36.99
37
123
5.9866
5.5
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}