package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:([89]|[12][0-9]|3[0-5])(\.[0-9]{1,2})?|36)$`)
var str = `8.5
9.56
10.69
35.99
36
36.99
37
123
5.9866
5.5
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}