using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:([89]|[12][0-9]|3[0-5])(\.[0-9]{1,2})?|36)$";
string input = @"8.5
9.56
10.69
35.99
36
36.99
37
123
5.9866
5.5
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}