$re = '/^(?:([89]|[12][0-9]|3[0-5])(\.[0-9]{1,2})?|36)$/m';
$str = '8.5
9.56
10.69
35.99
36
36.99
37
123
5.9866
5.5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);