using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((AND|OR|NOT)( ))?([a-z_A-Z0-9]*):(""\w+.*""|\w+(:?\w+))";
string input = @"homo sapiens AND curationstatus:""Manually curated"" AND modellingapproach:""Ordinary differential equation model""
test AND UNIPROT:23456 AND metabolism AND heart AND TAXONOMY:40674 AND curation:""Non curated"" AND GO:GO:34212 AND publication:23444 AND modellingapproach:""logical model"" AND cancer
modelformat:""SBML"" AND modelformat:""SBML"" AND modellingapproach:""Ordinary differential equation model"" AND TAXONOMY:9606
*:* AND modelformat:""SBML"" AND modellingapproach:""Ordinary differential equation model"" AND TAXONOMY:9606 AND TAXONOMY:10090
*:* AND disease:""Lung Adenocarcinoma"" AND cancer AND tumor";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}