package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((AND|OR|NOT)( ))?([a-z_A-Z0-9]*):("\w+.*"|\w+(:?\w+))`)
var str = `homo sapiens AND curationstatus:"Manually curated" AND modellingapproach:"Ordinary differential equation model"
test AND UNIPROT:23456 AND metabolism AND heart AND TAXONOMY:40674 AND curation:"Non curated" AND GO:GO:34212 AND publication:23444 AND modellingapproach:"logical model" AND cancer
modelformat:"SBML" AND modelformat:"SBML" AND modellingapproach:"Ordinary differential equation model" AND TAXONOMY:9606
*:* AND modelformat:"SBML" AND modellingapproach:"Ordinary differential equation model" AND TAXONOMY:9606 AND TAXONOMY:10090
*:* AND disease:"Lung Adenocarcinoma" AND cancer AND tumor`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}